Books added auto-default to lowercase letters

ConversazioniBug Collectors

Iscriviti a LibraryThing per pubblicare un messaggio.

Books added auto-default to lowercase letters

1GREGandDANICA
Nov 14, 2021, 9:56pm

I've noticed over the last several weeks whenever I am adding any books using the barcode scan function of the Android app that every book title defaults to all lowercase letters (including the first character of each word), with the exception of the first character of the first word. When manually searching, every result has the same issue. The first character is capitalized and everything else is lowercase, like it's a sentence.

It occurs for every book - no exception. Forced into saving them this way and editing the title after. Pretty annoying.

2AnnieMod
Modificato: Nov 14, 2021, 10:10pm

What source had you selected as your main one?

LT pulls the title from your selected source basically - so if they are returning all small letters, LT saves that. Maybe there is a better source to select for your specific set of books?

Unless something else is going wrong but try to change the source and see if that may fix it?

3lorax
Nov 15, 2021, 9:57am

This is not a bug. This is that the source you're using uses "sentence case" rather than "title case". It's just a different standard; neither one is right or wrong. Choose a different default source if you prefer title case.

4kristilabrie
Modificato: Nov 22, 2021, 9:19am

I'm sorry for the inconvenience, but I've tested this on my end and I'm not seeing a bug. We're grabbing the data directly from the source (I tested this on the backend for a number of your recently-added titles).

5Crypto-Willobie
Nov 16, 2021, 4:22pm

Many/most libraries will give you sentence case.
Amazon will usually give you title case but also a bunch of other problems.

6jjwilson61
Nov 17, 2021, 10:03am

Yeah, sentence case isn't wrong; it's standard practice for libraries.

7CovenantOPC
Nov 17, 2021, 6:56pm

When I change my entries to title case, they used to stay that way. I just now looked at my library list in "Your books", and it changed a bunch of them back to sentence case. I double-clicked on the title and fixed it on many of them, but when I scrolled down and back again it defaulted back to sentence case. So now it appears I am unable to change them. Something must have changed, because it always let me edit them before. I really don't want to edit through a thousand entries all over again, especially if they don't stay fixed.

8jjwilson61
Nov 17, 2021, 7:14pm

>7 CovenantOPC: If that's happening then it's a very serious problem so I've reopened the bug report. Your own data should never change unless you change it.

9Crypto-Willobie
Nov 17, 2021, 7:31pm

>7 CovenantOPC:
Give us an example title where it has changed.

10AnnieMod
Nov 17, 2021, 8:35pm

>7 CovenantOPC: You do press Save (or enter to Save) after you finish editing the field, right? (just making sure - I was caught a few times in forgetting to do that for one reason or another).

Also - if you cannot change them, that's weird. What browser are you using?

11r.orrison
Modificato: Nov 18, 2021, 4:20am

Are you changing your title on the Edit Book page, or are you changing the title for everyone using the CK Canonical Title field? If you do the latter, other people can and will undo it. If you edit your copy of the data on the Edit Book page, nobody else can change that.

12lorax
Nov 19, 2021, 9:25am

And you absolutely should not use Canonical Title to set your preferred case.

13CovenantOPC
Nov 21, 2021, 10:20pm

>10 AnnieMod: Thank you for looking into this. I did verify that I pressed "save" since at first I thought that was my problem. I use the Firefox browser. I realized today that I've only noticed it while in the "Your books" tab while doing a search on a word, so that might be a place in the programming to check. Today I tried to recreate the same issue using the same search word "suffering" and change the book "Name Above All Names" and some others. I scrolled down and back up again and they went back to lowercase. Then I thought to remove the search term and look at the entire list of books in "Your books". I set it to order by name and found that book, and it was back to upper case! So maybe it's just something about the software displaying it incorrectly in that screen. I tried some more and didn't have any further issues using other search terms, so it seems to be intermittant. (Note that the earlier books added to our library do have some lower-case titles, because I didn't realize it was bringing them in that way. I still need to go through and update those. But I was watching for this in the later books.)

14AnnieMod
Nov 21, 2021, 10:23pm

>13 CovenantOPC: It was just the lack of refresh on the front end (your side).

Basically the browser is trying to help you so unless you refresh (F5 on browsers on Windows or Ctrl+F5 for a full refresh) or force it to show the new data, it may show you cached data (or you have an add-on "helping" even more). Which is not something the developers can help with - your browser is trying to be "helpful". When you reorder/re-search again or refresh, you force a new pull from the server so the cache is not playing.

15CovenantOPC
Nov 22, 2021, 2:55pm

Ok, I'll try the refresh. I thought after going back in a few days later there were still some that were back to lowercase, but I could be mistaken as to whether those were ones I edited. Once I get all the older titles updated, I'll be able to tell more easily if it happens again. Thank you!