Can't add books

ConversazioniBug Collectors

Iscriviti a LibraryThing per pubblicare un messaggio.

Can't add books

1BookConcierge
Modificato: Ott 25, 2021, 5:02pm

I went to the ADD BOOKS page
I typed in the isbn of Circe by Madeline Miller - hardcover edition.
The book popped up, but when I click on it, I just get a never-ending "dot-dot-dot" symbol for "processing" and it never populates.

I've tried the 10-digit ISBN, the 13-digit ISBN ... and then tried just typing in the title. This last effort brought up only the paperback version, but I get that same never-ending processing symbol when I tried to add that one.

About to try a completely different title, but I don't feel optimistic that it will work any better.

2BookConcierge
Ott 25, 2021, 4:41pm

UPDATE ... after letting the processing go uninterrupted, I eventually I get 405 not allowed error message.

3Foretopman
Modificato: Ott 25, 2021, 4:45pm

>1 BookConcierge: Which source are you searching? What happens if you search a different source for Circe?

edited because I didn't read the OP carefully enough

4MarthaJeanne
Modificato: Ott 25, 2021, 4:53pm

There is no 9 digit ISBN. Only 10 or 13.

I suggest trying another source, and not Amazon.

5SandraArdnas
Ott 25, 2021, 4:53pm

Sounds like server problems with the source. Try another one, or Overcat which might even have the data from the same source, but stored locally on LT

6rosalita
Modificato: Ott 25, 2021, 4:59pm

I think this might be a more general problem — at least, I am also having trouble adding a book.

Just now, I tried adding The Secret Lives of Color, using the ebook ISBN (9781524704940) and the hardcover ISBN (9780143131144) on Overcat and a couple of other sources that usually turn up ebooks reliably (Brooklyn Public Library and Seattle Public Library). Each time the search churned for nearly a minute before returning the message "The search has failed."

I also tried Library of Congress but got a message that LT is aware that they are having connection problems with that source.

I also tried search by title and got the same non-results and search failed message.

7MarthaJeanne
Ott 25, 2021, 4:57pm

Tried circe, Miller on several sources. Problem seems to be LT.

8saltmanz
Modificato: Ott 25, 2021, 5:04pm

I just acquired CIRCE a week or so ago, and tried re-adding it just now the same way I added it back then: ISBN 9780316556330 from Amazon books. I also get the same result as >2 BookConcierge:

9susanwithagoodbook
Modificato: Ott 25, 2021, 5:06pm

That's happening for me, too. I mean, I'm trying to add books and getting the never-ending dots or a 405 not allowed error message.

10BookConcierge
Ott 25, 2021, 5:06pm

To be clear ... on the ADD BOOKS page
I type in the ISBN in the search field ... I took the info directly from the physical book itself.

When I click search it DOES bring up the book in the right hand column (at the top of which it states it is from Amazon ... I don't know how to change this field, if I can)

When I click on the book itself to add it to my shelf, it get that "processing symbol" for quite some time and eventually get the 405 not allowed error message.

11viking2917
Modificato: Ott 25, 2021, 5:09pm

same issue, but with the book 1066 by Haworth, and other books as well.

Oddly, although the page never returned from the " . . . " waiting state, a few minutes later when I returned to the home page the book had been added.

Other books, however did not add at all, even after waiting.

Adding a book makes calls to
https://www.librarything.com/addbook_regular.php,
which never return, just show "pending" in Chrome developer tools.
-----
belay that... after 3 - 4 minutes, other books do in fact show up in my account. Sounds like a very overloaded server perhaps?

12rosalita
Ott 25, 2021, 5:08pm

>10 BookConcierge: Well, that's not fair. I can't even get it to serve up a list of matches!

13BookConcierge
Ott 25, 2021, 5:10pm

Addition information on the "error message"

The error message is printed in the right-hand column, like this:

405 Not Allowed
_____________________________________________
nginx/1.21.3

14BookConcierge
Ott 25, 2021, 5:12pm

>11 viking2917: I also saw that a different book, which initially gave me the same error message, WAS on my shelf when I went back to the add-books page. I was able to add my review, date read, etc and save to my shelf.

But repeated tries for Circe by Madeline Miller result in the same error message and the book does NOT show up on subsequent visits.

15knerd.knitter
Ott 25, 2021, 5:32pm

There are some issues going on with the Add Books screen at the moment. We are looking into it. Most sources seem to be working again, but Overcat is currently not returning results.

16timspalding
Ott 25, 2021, 5:33pm

conceptdawg, myself and knerd.knitter have been working the problem. It seems like we had some sort of network problem and it freaked out everything. Everything is now recovering, but Overcat went down. We are waiting to get it up again.

17BookConcierge
Ott 25, 2021, 7:57pm

Thank you! It's working now.

18kristilabrie
Ott 26, 2021, 8:04am

Marking as fixed.

19susanwithagoodbook
Ott 26, 2021, 10:16am

Yes. It's working now. Thank you.