Missing Work ID

ConversazioniBug Collectors

Iscriviti a LibraryThing per pubblicare un messaggio.

Missing Work ID

1shadrach_anki
Apr 16, 2019, 1:58pm

In my library I have cataloged a copy of The Penderwicks at Last by Jeanne Birdsall. When I look at the book in my library, it shows that there are 117 members who own it and 4 reviews. When I mouse over the link leading to the work page, I see the following URL: https://www.librarything.com/work/20891039/book/163591179 .

When I click on the link, I am brought to a page without the work number (URL: https://www.librarything.com/work/book/163591179 ). This page still shows 117 members, but indicates there is only a single review of the book. However, if I click on any of the left sidebar links (Work details, Members, Editions, etc) I am brought to a completely different work ID: https://www.librarything.com/work/16060008/workdetails

This second work is an audiobook version of The Penderwicks at Last, but it only shows 6 members (I am not one of them). This is the work that shows up on the author's page and on the series page. So even though I own a copy of the book and can search for it in my library, when I am looking at other places on LibraryThing the green checkmark indicating I have the book in my library does not show up.

I do not know if this problem is occurring on any other works, but it is affecting at least this one.

2lorannen
Apr 16, 2019, 2:14pm

>1 shadrach_anki: So, the missing work ID isn't actually an issue—it's just another way that book URLs can function. I'm not sure why they happen that way sometimes (would have to get Tim to weigh in on that), but the link still works and gets you to a book page. I suspect it may have something to do with recent combinations, but I'm not sure.

What I do see as a problem is 1) the fact that you have a copy of a work in your library, but aren't seeing those green checkmarks. This same issue came up a few weeks ago for a different member—I'm still not sure of the initial cause, but in the previous case, clearing that member's caches resolved the issue. I've cleared your caches now. Can you tell me whether you're seeing the green check marks now?

The other problem is 2) the discrepancy between the number of members reflected here. I'm still working on figuring that out. This page: https://www.librarything.com/work/20891039 redirects here: https://www.librarything.com/work/16060008. The former, by way of your individual book, reflects that 117 members have this book. The latter, only 6.

3lorax
Apr 16, 2019, 2:16pm

Work numbers redirecting, and discrepant counts, are often the result of a recent combination or separation where the system hasn't fully caught up yet. "Recalculate title/author" sometimes fixes this.

4lorannen
Apr 16, 2019, 2:23pm

>3 lorax: Thanks for the suggestion! I tried the recalculate title/author process, and no dice. Though I'm pretty sure you're right about combination needing to catch up.

5shadrach_anki
Modificato: Apr 16, 2019, 2:41pm

>2 lorannen: I am still not seeing any green check marks for this book.

Edited to add: I have a second account that contains an import of my Goodreads account (shadrachanki), and that account is showing the same "no checkmarks" behavior for this book.

6norabelle414
Apr 16, 2019, 2:42pm

I wonder if this is related to this bug: https://www.librarything.com/topic/303847 in which case the lack of work number might be a red herring.

7shadrach_anki
Apr 16, 2019, 2:50pm

>6 norabelle414: The behavior certainly seems the same...

Another piece of data that may be useful: when I am in my catalog looking at this book, and I click on the 117 next to the members icon or the 4 next to the reviews icon (in the rightmost column), I am taken to an error page that states: "Problem: There is no work with that reference number."

8saltmanz
Modificato: Apr 16, 2019, 3:06pm

>7 shadrach_anki:

Ah, I see that the members and reviews links from your catalog are still pointing to work# 20891039, which does not exist, when they should be redirecting to the new work# 16060008.

So https://www.librarything.com/work/20891039/book/163591179
redirects to https://www.librarything.com/work/book/163591179

But https://www.librarything.com/work/20891039/members/163591179
and https://www.librarything.com/work/20891039/reviews/163591179
do not properly redirect.

Really, it looks like any link without the book# isn't forwarding to the new work#. I would expect this to sort itself out in no more than a couple hours, but...

9shadrach_anki
Apr 17, 2019, 1:44pm

Reporting in to state that after nearly 24 hours there does not seem to have been any change on this record. I still have no green check marks indicating book ownership, and the previously mentioned forwarding is still broken. This holds true for both my accounts.

10shadrach_anki
Apr 24, 2019, 3:24pm

Informational update: One person has added the book to their catalog in the intervening week, but the book record persists in showing just the audiobook version with its single review and six members. Still no green check marks indicating ownership, and the link forwarding from the catalog view is still broken.

After more than a week, it seems unlikely this is merely the result of the system needing to catch up to recent combination/separation actions.

11davidgn
Apr 24, 2019, 11:37pm

I can report I've had a very similar experience, and it remained in that state for days. I ultimately just deleted my record. Not sure if I can replicate.

12norabelle414
Maggio 7, 2019, 1:09pm

Bump

13shadrach_anki
Maggio 7, 2019, 2:29pm

Adding to the above bump: I still do not see any check marks showing up for this work. The links in my catalog that go to members and reviews for this work still get me that error page I mentioned in >7 shadrach_anki:. And this information holds true for both my accounts. I can also confirm that the catalog links are broken when viewing the catalogs of other people who have this work (I can see the members who recently added the book if I go to the work page from my catalog).

14shadrach_anki
Maggio 16, 2019, 2:36pm

Bump

15MarthaJeanne
Maggio 16, 2019, 2:46pm

This really seems to be a combination that only partly went through.

16shadrach_anki
Maggio 16, 2019, 2:58pm

If it is a combination that only partly went through, is there any way to fix it? Simply waiting hasn't made a difference, and since three people have added the book since I made my first post, I rather doubt that deleting the work and readding is going to have any effect either.

17MarthaJeanne
Modificato: Maggio 16, 2019, 3:23pm

I played with it a bit, and for a short time the larger number of copies showed on the author page. I think a developer is going to have to deal with it. Most of the editions are not accessible to members. (Not even when I saw the larger number.)

18lorannen
Maggio 16, 2019, 4:44pm

Yeah, this has proven trickier than I thought. I'm working on flagging down a developer to help.

19shadrach_anki
Giu 2, 2019, 9:51pm

Bump

20shadrach_anki
Lug 23, 2019, 1:33pm

Bump. The majority of users with this work still seem to have their records located on the phantom work 20891039. Catalog links to members and reviews are still broken as a result, and the check marks showing the book is in your library do not appear.

At least a few more people have added this book since I last checked, and I did some combination work with a couple of German editions today in the hopes that it would unstick things somehow (does not seem to have had much of an effect).

21shadrach_anki
Ago 21, 2019, 1:25pm

Bump.

German editions are now combined in properly, but everything else is still in the same weird limbo state.

23FAMeulstee
Set 23, 2019, 1:02pm

I have a recently added book that doesn't combine right with the work, number of copies stuck on 1.
The book doesn't show at the author pages as owned by me.

My copy: https://www.librarything.com/work/book/173261489 shows 1 copy of the work. The tags and ratings of the work are visible here.
My copy is not listed in editions: https://www.librarything.com/work/12506310/editions/173261489, there are 39 copies of the work.

I have tried recalculating to no avail. Not sure what else I can do.

25kristilabrie
Modificato: Nov 12, 2019, 3:20pm

Just summarizing this one for developers to look into.

For devs:
1. Go to https://www.librarything.com/catalog/shadrach_anki&deepsearch=penderwicks+at.... Note the URLs for the members and reviews icons for the book (in the tool area) show work number 20891039.
2. Click on the title for The Penderwicks at Last. (NB: URL doesn't include the work number: https://www.librarything.com/work/book/163591179.)
3. Click on any of the links in the left-hand menu of the work page. See work number in URL is now 16060008.
4. If you go back to https://www.librarything.com/catalog/shadrach_anki&deepsearch=penderwicks+at... and open the members or reviews links in the tool area, you get https://www.librarything.com/problem/18, "There is no work with that reference number." error message.
5. The same thing is happening for AbigailAdams26: https://www.librarything.com/catalog/AbigailAdams26&deepsearch=title%3A+pend....

Bug: There is a phantom work number 20891039, for which members with that work aren't showing up on work number 16060008. Perhaps a failed work combination of sorts.

26kristilabrie
Nov 12, 2019, 3:17pm

>23 FAMeulstee: I'm getting a different work number for your book (which is actually showing 41 members now): https://www.librarything.com/work/4306965/members/173166987 than the work here: https://www.librarything.com/work/12506310. It looks like your work is the "First Half" and the other work is the "Second Half", so should stay separate. Yes?

27norabelle414
Nov 12, 2019, 3:51pm

I think that the origin of this bug might be what I have detailed in another bug report: https://www.librarything.com/topic/312780 where I added a book and two works were created instead of one

28FAMeulstee
Modificato: Nov 12, 2019, 4:59pm

>26 kristilabrie: Yes, those are seperate books.
It was the Second half where the problem was. I just added it again and this time it went well.

ETA: Went wrong again... https://www.librarything.com/work/book/175349024
Won't touch until you say I can.

29norabelle414
Nov 25, 2019, 2:12pm

30FAMeulstee
Modificato: Gen 4, 2020, 5:06am

>26 kristilabrie: The problem still persists my book https://www.librarything.com/work/book/175349024 is connected to this work https://www.librarything.com/work/12506310 But at this work page my copy is not there, I get the add book option. Neither does it show at the editions page.

ETA: the work you mentioned (https://www.librarything.com/work/4306965/members/173166987) is the first part of book 4, the problem is with the second part of book 4.

31kristilabrie
Gen 10, 2020, 8:52am

Another report of this bug: https://www.librarything.com/topic/303847.

32MissWatson
Feb 3, 2020, 5:21am

Could this be a related problem?
I'm not quite sure why my newly acquired copy of La fille de Vercingétorix doesn't show up on the main page or the author page of Jean-Yves Ferri:

My copy
https://www.librarything.com/work/book/178381302

Author page Ferri
https://www.librarything.com/author/ferrijeanyves

Works page as accessed from author page
https://www.librarything.com/work/23624574

33MarthaJeanne
Feb 3, 2020, 6:03am

>32 MissWatson: When accessed on Profile page you get the proper work with 119 members. When accessed in the catalogue, no work number, 2 members.

34MissWatson
Feb 3, 2020, 6:40am

>33 MarthaJeanne: So – what do I need to do to see the green checkmark on the author page?

35MarthaJeanne
Feb 3, 2020, 6:51am

>34 MissWatson: I don't think you can do anything, but that information might help the developers figure out what is going on.

36MissWatson
Feb 3, 2020, 8:06am

37aspirit
Modificato: Mar 3, 2020, 10:20pm

I seem to have found this bug with Let's Play, Crabby! by Jonathan Fenske.

My library links to https://www.librarything.com/work/book/179317455.

The work page linked to the author page is at https://www.librarything.com/work/23537299. (The author page is at https://www.librarything.com/author/fenskejonathan. As a side note, that page is showing as insecure.)

Typing the work ID into my edition's address brings up the correct page: https://www.librarything.com/work/23537299/book/179317455. However, I don't see a way to get there without typing in the address. (ETA: There is data missing.) I am also missing the check on touchstones for that work.

38aspirit
Modificato: Mar 1, 2020, 11:28am

It's definitely the same bug. All the problems are the same.

The members counts are wrong. I don't appear in the list of members on the main work page.

https://www.librarything.com/work/23537299/members/179317455

My review shows up on none of the work's public-facing pages.

39aspirit
Modificato: Lug 31, 2020, 3:06pm

>2 lorannen: said,
I'm not sure why they happen that way sometimes (would have to get Tim to weigh in on that)

Tim didn't weigh in for ten months. Then when I referred to this thread where it seemed relevant,
he said there
, not here,

There is no missing work-id bug, as the second message explains.


This certainly looks like a bug. I see no actual explanation in message #2 of how it's not.

We members don't know why the work is missing in some links. What we do know is that once a book entry generates the link without the work ID:

-- any following book entry goes to the work version that does not include the work ID (so deleting the edition to re-add it is useless)
-- editions without a work ID in the links from members' libraries cannot be combined with editions that have a work ID
-- links from missing-ID works to member catalogues are broken, resulting in an error

-- edition data for the members with the missing-ID work does not appear on the work's main page
-- reviews (including ER reviews) for the missing-ID books are not counted
-- reviews for the missing-ID books are not visible on the work page

-- the missing-ID work editions do not count toward the main (ID'd) work
-- the missing-ID work editions do not appear in searches
-- missing-ID work editions are not included in links from author pages (see message #67 for an update)
-- checkmarks do not appear on touchstones or lists for the members with that missing-ID work

Did I leave out anything significant? (ETA issues.)

40aspirit
Mar 3, 2020, 10:30pm

I'm changing the status to "Needs discussion" as there's an obvious need to discuss with the LT team how or if the problem described by the OP is a "bug".

41aspirit
Modificato: Mar 5, 2020, 11:51am

Touchstones for books that have reported (in this thread and linked threads) as missing work IDs.

The Penderwicks at Last
Het Koninkrijk der Nederlanden in de Tweede Wereldoorlog. Deel 4
Joy to the World How Christ's Coming
La fille de Vercingétorix
Let's Play Crabby
The Hollywood Book Club

The versions missing work IDs must be accessed through member libraries. This list is of the main works.

42MarthaJeanne
Modificato: Mar 4, 2020, 4:18pm

43FAMeulstee
Modificato: Mar 4, 2020, 4:40pm

>39 aspirit: Thank you for putting this together, I think it is a complete listing of the problems.

>40 aspirit: The touchstone of the work should be Het Koninkrijk der Nederlanden in de Tweede Wereldoorlog. Deel 4, 2e helft
(I had to add the worknumber (12506310) to make the touchstone work, my book is https://www.librarything.com/work/book/175349024, now 2 members have this entry)

ETA: one more problem, when I click on members (2) of the book in my catalogue I get this: Problem There is no work with that reference number.
(https://www.librarything.com/problem/18)

44aspirit
Mar 4, 2020, 5:22pm

>43 FAMeulstee: thank you! Is the touchstone correct now?

Ahh, I saw that reference number error reported in another thread and didn't understand it. I'm not sure how to state the problem. "Missing-ID works do no link to a members list (Problem 18)"?

45aspirit
Mar 4, 2020, 5:32pm

>42 MarthaJeanne: thanks for the link. I'd tried finding definitions in the main search but came up with none. Although, I'm confused by your statement. Priorities aren't noted on that page.

What is says,
Needs Discussion
When you don't understand the bug as reported.
Fix for the bug needs discussion (i.e., "What should it do?").


My reasoning: The LT team doesn't understand the bug as reported and needs to read the discussion. That is, unless Tim wants this behavior in works for some mysterious reason. If the missing work IDs are not a "bug" but something intentional on his side, then I think we all deserve an explanation for what should happen. Otherwise, we won't know how to report the problems that he is willing to have fixed.

46FAMeulstee
Mar 4, 2020, 5:33pm

>44 aspirit: Maybe "Missing-ID works do not link to members from the catalogue, gives error"

47norabelle414
Mar 5, 2020, 9:03am

>45 aspirit: I think the confusion is coming about because there are times when a URL can be missing a work ID but this bug is NOT present, so I'm not sure it's accurate to call this the "missing work ID" bug. Missing work ID is a symptom of the problem but it's not the problem itself.

48aspirit
Mar 5, 2020, 10:04am

>47 norabelle414: I have three main thoughts on that.

(1) Do we have any example of a work that is added to a catalogue without a work ID but doesn't have these problems?

(2) What else would we call the bug? The common denominator appears to be the missing work ID. Something behind the scene is causing the missing ID, but we have no clue as to what that is. It only makes sense to identify the problem with what we know.

(3) "So, the missing work ID isn't actually an issue" was a mistaken assumption that wasn't addressed by the LT team. Tim was (to put this politely) inaccurate in saying message #2 in this thread. He could have checked the most recent messages before asserting this is "not a bug" that needs to be addressed. He's pretty much said that he's going to continue to ignore our frustrations and not have the problems resolved unless he happens to make a fix by working on (only) the ER problem. Meanwhile, members are losing access to the site's primary features.

49norabelle414
Mar 5, 2020, 10:54am

>48 aspirit:

(1) I don't think we have evidence that the books so not have a work ID when they are added to the site*. Sometimes book URLs don't have work IDs because their work has been combined, moving the book ID from one work ID to another work ID. The work ID might be lost later. Especially since as mentioned in >8 saltmanz: there are two work numbers for The Penderwicks at Last (and two work numbers for Selected Poems by D.H. Lawrence on the other thread), they're just not properly combined together.

(2) I like "books in limbo" or "works not properly combined" or "phantom work" as mentioned in >25 kristilabrie:

(3) The fact that the work ID is missing is not itself an issue, but I agree that it's annoying that he did not read further on this thread (especially since several other threads with examples of this bug have been closed as duplicates and redirected here). It's very frustrating that this bug was reported almost a year ago and there's been no movement.

____________________

*My personal conspiracy theory is still that this bug: https://www.librarything.com/topic/312780 (when I manually add a "book" that no one else has, it creates two works) is the origin of this bug.

50norabelle414
Mar 5, 2020, 10:54am

>41 aspirit: My issue with Life of Pi looked the same but it was resolved by clearing my cache so it was apparently not the same bug.

51aspirit
Mar 5, 2020, 11:58am

>50 norabelle414: thank you for pointing that out. I've removed the work from my list.

For my curiosity, I checked the link from your catalogue: https://www.librarything.com/work/5197633/book/18309185. Yep, there's a work ID. Lucky book.

52aspirit
Mar 5, 2020, 12:20pm

>49 norabelle414: we might have to disagree about terminology. In my view, an address directing to the correct book without a work ID is not the same as a missing-ID book, which has pages that do not function as expected by us members who were taught to expect books to be searchable, combinable, and reviewable.

For alternative phrases:

I dislike "books in limbo" or "works not properly combined" for implying that we can either (1) wait for the system to sort out these books or that we (2) can combine the searchable books with work IDs with the ones the hidden books without work IDs. We can't combine them. Waiting doesn't seem to be any more effective than refreshing or clearing out a cache (on the member side).

A "phantom work" brings to mind the works that have zero copies. I could say missing-ID books are phantom books is that are kind of dead compared to books with IDs, and they're hard to see. What goes against that phrasing is how these phantoms grab at new entries. They're more like vampires. Also, we'd be ignoring how we can identify when these books are victims of this bug instead of another: the missing work ID from the catalogue link.

53FAMeulstee
Modificato: Mar 6, 2020, 5:17am

A "missing work-ID" in itself is not a fault. If you click on a book title on your profile, you go to a page without work-ID, only the book-number like: https://www.librarything.com/work/book/174440758

The problem is that there is no LINK between the book and the work, it is missing or corrupted. And it is not possible to correct it with combining or other tools.

54r.orrison
Mar 6, 2020, 6:05am

This is clearly a bug which affects certain books. To summarise with examples from above:

A normal book URL without work id looks like this: https://www.librarything.com/work/book/174440758 These are legitimate URLs and the site uses them in many places. For example, on a member Profile page in the "Currently reading" section.
Note that there are 933 members with that work. Click on "Work-only work page" on the right side of the page, that takes you to
https://www.librarything.com/work/195096/work/174440758
which also has 933 members. It's the same work and the book is correctly connected to the work.

A broken book URL without work id looks exactly the same: https://www.librarything.com/work/book/175349024 This URL comes from the profile page of FAMeulstee in the "Currently reading" section.
There are 2 members with that work. If you click on "Work-only work page" on the right side of the page it takes you to
https://www.librarything.com/work/12506310/work/175349024
which has 39 members.

The book is not properly connected to the work.

55aspirit
Modificato: Mar 22, 2020, 5:14pm

>54 r.orrison: thank you for the summary. I think there's been misunderstandings about what this situation looks like.

>53 FAMeulstee: Your link in this thread didn't take to a page that loads correctly. My device is giving up on the load or refresh after roughly 2.5 minutes. Something is wrong there. ETA: The page is loading now. It's a good example, because the catalogue link without a work ID connects to the main work. I'm guessing you can see checkmarks for that work and everything.

edited for conciseness

56norabelle414
Mar 6, 2020, 4:13pm

Another one. They've added both the "good" and "bad" works to their catalog, so it's easy to see:
https://www.librarything.com/catalog/moibibliomaniac&deepsearch=hollywood+bo...

One book's link goes to https://www.librarything.com/work/23701683/book/179529850
The other book's link says https://www.librarything.com/work/23660765/book/179061136 but then redirects to https://www.librarything.com/work/book/179061136

57FAMeulstee
Apr 2, 2020, 5:21am

I recently added a book https://www.librarything.com/work/22601731 when I go to the work page I am noted at "recently added" and listed with the members, but it doesn't show the book is in my catalogue. The "Add to your books" button shows.
I can only get to my copy through My Library https://www.librarything.com/work/22601731/book/180665878
It was added on 2020-03-28

58MarthaJeanne
Modificato: Apr 2, 2020, 6:18am

>57 FAMeulstee: Check which collection you are searching. It shows in your catalogue, but is only in two collections: To read, TIOLI

59FAMeulstee
Apr 2, 2020, 8:21am

>58 MarthaJeanne: I can find it in my library. When I click the touchstone in a thread, I get the work page with the "Add to your books" buttton.

60aspirit
Modificato: Apr 15, 2020, 11:16am

>59 FAMeulstee: do you see a checkmark for the touchstone in this thread's sidebar? (Sounds to me that you don't. My question is a request for confirmation.)

Dichter in de jungle (removed)

61FAMeulstee
Apr 2, 2020, 12:45pm

>60 aspirit: Clever thinking, indeed there is no checkmark.

63aspirit
Apr 15, 2020, 11:15am

I've missed noting a few issues, but coming onto this thread makes me angry.

>62 FAMeulstee: Dichter in de Jungle seems to have not been the same issue. I think the problems continue with all the rest of the books listed here.

64shadrach_anki
Apr 15, 2020, 11:50pm

>63 aspirit:

I can confirm that the problems are still present for The Penderwicks at Last, a year after I first noticed and reported them. The phantom work ID is still grabbing most of the copies that get added to LibraryThing.

65aspirit
Apr 16, 2020, 7:35pm

Happy(?) anniversary, >1 shadrach_anki: bug report.

66aspirit
Modificato: Giu 27, 2020, 9:29am

There's a report for Utterly Dwarfed.

https://www.librarything.com/topic/310900#7139234

The rejected member's book is at https://www.librarything.com/work/book/182330204.

edited to correct the touchstone

67aspirit
Giu 8, 2020, 10:43am

>37 aspirit: I've looked to see how last week's changes to series impacted the book that's missing a work ID in my catalogue.

The series info shows up under Series & Relationships but not near the title at the top of the page.

The main work page, the one that has an ID, has both links to the (same) series.

Interestingly, the Members count on the two work pages (the one with a work ID and the one without) is now the same. Although, my review continues to not exist on the main page.

68norabelle414
Giu 8, 2020, 10:43pm

69aspirit
Giu 27, 2020, 9:28am

>66 aspirit: Order of the Stick: Utterly Dwarfed has been reported again but by a different user.
https://www.librarything.com/topic/321865

The rejected member's book: https://www.librarything.com/work/book/185568932.

70FAMeulstee
Modificato: Giu 27, 2020, 6:13pm

I have a new one to report Middaguur by Dörte Hansen. I added it a month ago. I waited a while hoping it would resolve in time.
My copy https://www.librarything.com/work/book/184038698

ETA: No checkmark in front of "Middaguur" in this threads right sidebar.

71MarthaJeanne
Lug 5, 2020, 5:43pm

72aspirit
Modificato: Lug 6, 2020, 12:16pm

>71 MarthaJeanne: I'm adding the book links for later reference.

The Burning White by Brent Weeks

The copies missing the work ID greatly outnumber the original (166:22)! That means the main work page and search results shows a small amount of the copies for the book. The majority of members who have this work in their catalogues won't see checkmarks for it on touchstones.

https://www.librarything.com/work/book/175787804

73aspirit
Lug 6, 2020, 12:47pm

>72 aspirit: I've just now remembered the same thing is happening with the work in >1 shadrach_anki: The Penderwicks at Last.

The page of The Penderwicks at Last that appears in search results shows 17 copies and 4 reviews for the work.

When I click on the page that doesn't appear in search results...
https://www.librarything.com/work/book/163591179...
there are 187 copies and 4 reviews.

Jeanne Birdsall's author page shows the smaller count of 17 copies.

Hundreds of copies are not showing up in counts on search results and author pages.

74aspirit
Modificato: Lug 6, 2020, 12:52pm

Should the category for this thread be "Missing books"? We can see our copies in our catalogues but not always in site searches.

75lorax
Lug 6, 2020, 2:43pm

aspirit (#74):

No. Site search is entirely separate from your catalog, and throwing up alarm bells about ZOMG MISSING DATA when that's not what's going on is neither honest, helpful, nor going to get the bug fixed any more quickly.

What might help is changing the status back from the very low-priority "Needs discussion" - which is generally used by devs to indicate that there's nothing here they can do until members weigh in with actual details, and thus there's no point in wasting time on the bug at the moment - to "Reopened", which I've done.

76aspirit
Lug 6, 2020, 7:17pm

>75 lorax: there is missing data.

Also, when was the status closed? I'm confused about why this thread had to be reopened.

77lorax
Modificato: Lug 7, 2020, 10:20am

aspirit (#76)

Not missing *books*, though, in the sense of being gone from your catalog (based on what you said in #74), just "not showing up in site search" which happens all. the. time. and is not a sign of anything missing.

You marked the bug as "Needs discussion" (thus lowering its priority from the previous status of "reported") on March 3.

78aspirit
Lug 7, 2020, 12:05pm

>77 lorax: "Needs discussion" closes the report? That's frustratingly unclear. It didn't say "Closed". A LT team member recently pointed to this thread as one that would be addressed but didn't reopen it.

just "not showing up in site search" which happens all. the. time. and is not a sign of anything missing

We're going to have to disagree about counts as missing, as I think hundreds of books (possibly more) being inaccessible except through direct links that do never appear in site searches counts. I consider finding works by titles or author searches, identifying how many copies are catalogued, and accessing other members' public reviews from work main pages as part of LT's core features. I'm not only here for my own catalogue data (or Talk).

Also, to confirm: are you saying work pages have been hidden from site search since before 2019?

79lorax
Lug 7, 2020, 2:02pm

No, it doesn't close the report! That would be "Closed by member". It moves it to "Needs discussion". Which is a state meaning "There is insufficient information given in this report to be acted on as it stands; more information needs to be provided by the users". It's meant that since the bug tracking system was introduced.

Not showing up in site search has been a problem since long before 2019, yes. It's almost always a temporary condition. What you've described here is different from that, and is undeniably a bug, but it's not a missing book bug. That doesn't mean it shouldn't be addressed! Just that "missing books" is the wrong way to categorize it.

81aspirit
Ago 21, 2020, 8:00am

Another work missing an ID so it won't show up in site searches or combine:

https://www.librarything.com/work/book/188330678

for Harper and the Fire Star by Cerri Burnell

82aspirit
Set 17, 2020, 6:55pm

Bump

84Maddz
Modificato: Dic 15, 2020, 2:08am

85ryner
Dic 30, 2020, 5:50pm

This is happening with The Labyrinth of Spirits:

My copy of the book is here: http://www.librarything.com/work/book/179351622
The primary title record is here: http://www.librarything.com/work/18799486

LT believes I have not completed the series, because my copy isn't attached correctly to the "real" record, so no green check mark. How to resolve? Thx.

86r.orrison
Feb 16, 9:19am

Bump: this is still happening https://www.librarything.com/topic/329797

87Conkie
Feb 19, 11:26pm

>86 r.orrison:
I believe this reported BUG is basically the same issue...
Link returns "There is no work with that reference number." https://www.librarything.com/topic/329925

88aspirit
Modificato: Feb 20, 12:15pm

The work is Marian Halcombe by Brenda Clough. My book entry is integrated with the main work page. zeborah's isn't, and it can't be combined.

https://www.librarything.com/work/book/196590527

89aspirit
Feb 20, 12:22pm

The work most recently reported in Combiners! (see >86 r.orrison:) is The Greyhound by Helen Griffiths.

This one looks a little different-- fuzzi's book has a work ID-- but some of the behavior is the same.

https://www.librarything.com/work/1419073/book/165345450

90timspalding
Mar 5, 3:40pm

I believe most of these are fixed. I ran a true-up on some work-edition data and I see the works in the list. Spot-checking, everything seems good.

Give it the night for the search index, though.

91FAMeulstee
Mar 6, 7:44am

>90 timspalding: Thank you!

92shadrach_anki
Mar 6, 1:13pm

>90 timspalding: Excellent news, thank you! I can see a check mark next to the book I reported, and everything looks properly connected now!

93fuzzi
Mar 7, 8:53am

>90 timspalding: thank you!

94humouress
Modificato: Maggio 3, 1:56am

I posted this in the current Combining thread:
I need help, please. I thought I would combine this myself but I can't work it out.

Who's That Earl

When I added 97851611075 to my books I only got two results, one with 1 member and one with 0 members so I picked https://www.librarything.com/work/book/199690435

Looking at the book, there are 25 members so I assume that the copy I picked is not combined. When I look at 'Editions' on my copy (1 member), it shows 25 members - so does that mean it's already combined? I'm confused.

ETA: it's not combined. If I click on the touchstone it doesn't show that I have added the book.


It looks like it's partially combined. If I click on Members or the 1 member on my copy's main page, it takes me to the page with 25 members but my name doesn't show on the 'recently added by' list.

95MarthaJeanne
Maggio 3, 2:15am

I am reopening this so that it gets looked at.

96humouress
Maggio 3, 2:21am

>95 MarthaJeanne: Oh, thanks. I didn't notice it was closed. ☺️

97FAMeulstee
Maggio 3, 6:57am

>96 humouress: It looks like it was a caching problem. You are one of the members with Who's That Earl now.

98humouress
Modificato: Maggio 3, 9:05am

>97 FAMeulstee: Great! Thanks :0)

ETA: ... but, as yet, I can't add a review by clicking on the touchstone.

99humouress
Modificato: Maggio 4, 1:40am

Weirdly, although I’m now showing as one of 26 members (25+1) when I click the touchstone for Who’s That Earl, the review box doesn’t come up either on the main page or the review page. So it’s still only partially combined?

100FAMeulstee
Modificato: Maggio 4, 3:05am

>99 humouress: That is weird indeed. If it still doesn't show in a few days, you might report it as a new bug.

ETA What happens when you write something in the review part of "Edit your book"?

101humouress
Maggio 5, 6:00am

>100 FAMeulstee: Hmm - there isn't an 'edit your book' for that one. It's as though I haven't added it to my books, even though my name is there.

103aspirit
Giu 8, 11:24am

>90 timspalding: For the record, my books in the Touchstones list no longer appear to be zombies.

104aspirit
Modificato: Giu 21, 10:22am

This has happened again, for A Lily Grove 2 by Claudia Wollny.

kirstenlund's books, invisible on the work page:
1. https://www.librarything.com/work/book/201869060
2. https://www.librarything.com/work/book/201869994

105MarthaJeanne
Giu 21, 10:31am

Let's reopen.

106kristilabrie
Modificato: Giu 21, 12:33pm

>104 aspirit: was reported at https://www.librarything.com/topic/333114 and https://www.librarything.com/topic/333116, which I've closed so we can keep track of it here. Just noting for the record.

107FAMeulstee
Giu 22, 4:07am

Looks like it also happend to me again, I added De 90ste verjaardag van Louis van Roosgaarde yesterday, but my copy https://www.librarything.com/work/book/201889443 isn't on the main page.

108kirstenlund
Giu 22, 11:55am

>106 kristilabrie: A Lily Grove 2 is now connected with the other books on the author's page.
Thank you

109FAMeulstee
Giu 23, 7:18am

>107 FAMeulstee: My copy is now connected.
Could have been updating delay, of if anyone did someting: thanks!